- Build your personal website Forum

I can't add my .zone domain


Hi everyone, I’m afraid I cannot add my .zone domain. I’ve made the required A-records and everything should be fine. However, I still get the error message invalid domain when I want to add the domain. :scream:


Hey @frankymartin221 thank you for reporting that. I see that .zone domains are not among the list of available domain names. I fixed it so you should be able to add your domain.


And don’t add http(s) to your domain! This will cause trouble with the ssl creation.


Great it worked out. Thank you @marco


Here is a list of the current supported domains.
If anything is missing let me know ae asia az ki pk cc cn in ir jp kr hk jo kz lk my nf ph ps sg tw vn cx fm io la mn nu qa tk tl tm to tv ws academy careers education training bike biz cat co com info me mobi name net org pro tel travel xxx blackfriday clothing diamonds shoes tattoo voyage build rocks network page cloud xyz builders construction contractors site equipment glass lighting plumbing repair solutions legal buzz sexy singles support cab limo camera camp gallery graphics studio guitars hiphop photo photography photos pics center florist institute christmas coffee kitchen menu recipes company enterprises holdings management ventures computer systems technology directory guru tips wiki domains link estate international land onl pw today im am at ba be bg pl by ch ee gg hu je nl no rs de es gr mk pt ro ru su ua cz dk eu fi fr pm re tf wf yt ie is it li lt lu lv md mp se si sk ac ag ai as pr tt bo bs bz ca cl cr dm gy lc ms cu do ec gt hn ht kn mx pe uy vc gd gs us sx tc vg cd cg cm mg mw na ug ly ng sc mu rw sh so st club kiwi uno email ruhr


I can find .page, so I think it is missing


thank you @marczopoo I’ve added .page to the list :+1:


Hi @marco

please add .tk or .cf domains?



Hi @cacmelo I’ve added both domain endings :+1:

1 Like

Hi @marco, is it possible to add .space extension also? When I try to add my domain I get a generic error and then my page is not loading


Now it seems to work!


Hi & welcome @zeruhur :wave:, good to hear that it worked out. Sometimes it takes some time for the host to change DNS settings (up to 24 hours)